Google login issues.
Incident Report for Insightly
Resolved
This incident has been resolved.
Posted about 1 year ago. Aug 20, 2018 - 21:05 PDT
Monitoring
The issue has been fixed. We are currently monitoring.
Posted about 1 year ago. Aug 20, 2018 - 19:08 PDT
Investigating
We are currently investigating reports of login issues when using Google authentication.
Posted about 1 year ago. Aug 20, 2018 - 15:50 PDT