Delay in AppConnect Recipe Execution and Workflows

Incident Report for Insightly

Resolved

We have implemented a fix for the issue and have had no delays over the past 18 hours.
Posted Jul 29, 2025 - 16:37 PDT

Identified

We've identified the cause, have eliminated the delays, and will be implementing a longer-term solution shortly.
Posted Jul 29, 2025 - 08:04 PDT

Investigating

Insightly is currently experiencing a delay in processing Webhook communication to external systems and triggering of AppConnect recipes of pp to 70 Min. We are working to reduce this delay back down to normal levels.
Posted Jul 28, 2025 - 16:28 PDT
This incident affected: Insightly Web App and Insightly API.