Application Performance
Incident Report for Insightly
Resolved
We've implemented a fix for the performance issue and have been monitoring its effectiveness over the past hour with no recurrence of any slowdowns.
Posted Apr 21, 2021 - 11:57 PDT
Identified
We are currently experiencing a slowdown in application performance, and are working on remediating the issue.
Posted Apr 21, 2021 - 10:19 PDT
This incident affected: Insightly Web App.