O365 Logins
Incident Report for Insightly
Resolved
We have deployed a fix for the login issues, and verified proper operation.
Posted Mar 02, 2022 - 13:21 PST
Identified
We have identified the cause of the login failures, and are working on a software fix.
Posted Mar 02, 2022 - 11:56 PST
Investigating
We are currently investigating an issue affecting some customers and their ability to login using O365.
Posted Mar 02, 2022 - 09:59 PST
This incident affected: Insightly Web App.