Delivery Issues Affecting Insightly Marketing Emails

Incident Report for Insightly

Monitoring

We have implemented a fix for the domain reputation issues and are seeing marketing emails successfully reaching inboxes again. We are currently monitoring at this time.
Posted Apr 28, 2026 - 16:56 PDT

Identified

We have identified that a specific email domain is currently being flagged by some providers, affecting the delivery of marketing emails. Our team is actively working on restoring. We will provide updates as we progress toward full resolution.
Posted Apr 28, 2026 - 15:59 PDT
This incident affects: Insightly Web App.