Delay in AppConnect Recipe Execution and Workflows

Incident Report for Insightly

Resolved

We have resolved the delays in processing Webhook communication to external systems, triggering of AppConnect recipes, and Workflows.
Posted May 29, 2025 - 15:50 PDT

Identified

We are currently experiencing a delay in processing Webhook communication to external systems, triggering of AppConnect recipes, and Workflows of up to 20 minutes. We are working to reduce this delay back down to normal levels.
Posted May 29, 2025 - 14:40 PDT
This incident affected: Insightly Web App and Insightly API.