Emergency Application Maintenance

Incident Report for Insightly

Resolved

We have completed the maintenance to address the application performance and stability issues.
Posted Aug 28, 2025 - 22:21 PDT

Identified

We are currently performing emergency maintenance on the Insightly CRM Web Application to address an issue impacting stability and performance. During this time, users may experience intermittent downtime or slower response times. We expect the maintenance to be completed by within the next two hours Updates will be posted here as the work progresses.
We apologize for the disruption and appreciate your patience as we work to restore full service.
Posted Aug 28, 2025 - 20:10 PDT
This incident affected: Insightly Web App.