Host Stability

Incident Report for Insightly

Resolved

This incident has been resolved.
Posted Jul 19, 2024 - 02:45 PDT

Monitoring

We've implemented a fix & monitoring the platform stability
Posted Jul 19, 2024 - 01:51 PDT

Identified

We've identified a problem & are working with the vendor towards a solution
Posted Jul 18, 2024 - 23:36 PDT
This incident affected: Insightly Web App and Insightly API.