Google Login Issues
Incident Report for Insightly
Resolved
Google has resolved all login issues with the Google G-Suite login process.
Posted Aug 19, 2019 - 12:50 PDT
Investigating
Some users are reporting issues when logging into Insightly using Google G-Suite Login. Google is working to resolve this issue as it is affecting many applications.
Posted Aug 19, 2019 - 11:33 PDT
This incident affected: Insightly Web App.