Email Sending
Incident Report for Insightly
Resolved
This incident has been resolved.
Posted 5 months ago. Jun 22, 2017 - 11:27 PDT
Monitoring
Service has been restored, and we will continue to monitor the performance.
Posted 5 months ago. Jun 22, 2017 - 11:08 PDT
Investigating
We are currently investigating problems with sending email from the application.
Posted 5 months ago. Jun 22, 2017 - 10:27 PDT