Slow page response times
Incident Report for Insightly
Resolved
We have resolved the network performance problems that affected Insightly page load times.
Posted over 2 years ago. Jun 11, 2015 - 09:16 PDT
Investigating
We are investigating a problem with slower than normal page load times in the web app.
Posted over 2 years ago. Jun 11, 2015 - 08:23 PDT